
Chapter 3 Sound Windows: 
Visibility, Views, Linkage, & Navigation

About this chapter

This chapter will explain how to work with and get around Raven in more 
detail. Before reading this chapter, you should have a solid understanding 
of the major components and basic layout that make up the Raven 
window. If you need to review this information, please see Chapter 1, 
“Getting Started” and Chapter 2, “The Raven Window”. Topics discussed 
in this chapter are:

•using contextual menus
•learning the basic layout of a sound window
•understanding the five main view types
•linking and unlinking of views
•controlling how views are displayed
•changing the appearance of a Sound window
•changing the appearance of the Raven window

Using Contextual Menus

As you learn more about navigating around the Raven window, you 
might realize that it would be convenient to have a list of contextually-
oriented commands readily available. Well, luckily for our users, there is 
such a list. A context menu is a menu of useful commands that apply to 
wherever your mouse pointer is positioned at that time. To activate a 
context menu, simply right-click using your mouse (or Control+click on a 
Mac) and the menu will appear.
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Figure 3.1 Context menu example

Figure 3.1. An example of a context menu when the mouse pointer is 
over a waveform view. The menu gives you many command options 
relevant to the mouse location and is accessible by a simple right-click 
of the mouse (or Control+click on a Mac).

Basic Layout of a Sound Window

This section contains information regarding the general makeup of sound 
windows. To review how to open a sound window, refer to “Opening a 
sound file” in Chapter 1 (page 2).
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Figure 3.2 Sound Window

Figure 3.2. A basic sound window containing two views (a waveform 
view, top, and a spectrogram view, bottom) with the view axes (both 
vertical and horizontal) marked in red. Each axis is marked with a unit 
and number values.

The active view Most commands, buttons and scroll bars that affect views apply only to 
the active view. Only one view in a sound window can be active at any 
given time. The active view is identified by a colored vertical view selection 
button at its left edge. The name of the active view is also highlighted on 
the side panel’s Layout tab. In Figure 3.2, the waveform is the active view. 
To activate a view, click on its view selection button or in its axis areas. You 
can also activate a view by clicking on its name to select it in the side 
panel’s Layout tab.

Moving, resizing,
and closing a sound

window

The sound window’s title bar has controls for resizing and closing the 
window, and is the means by which you move a sound window. See 
Figure 3.3.

Although you can activate a view by clicking in the data 
region (i.e., above and to the right of the axes), doing so will 
create a selection. Basic information about selections can be 
found in “Making a selection” in Chapter 1 (page 9), while 
more advanced selection information is discussed in Chapter 
6, “Selections: Measurements, Annotations, & Editing”.
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Figure 3.3 Moving and Resizing a Sound Window

Figure 3.3. The title bar, with controls to resize and close a sound 
window. The title bar is also the anchor for moving the sound window.

To move the window around, simply click and drag on the title bar. 

To minimize the window (to reduce the whole window to a short title bar 
at the bottom of the Raven window) click on the Minimize icon in the title 
bar. Clicking on a minimized window’s title bar expands it again. 

Clicking on the maximize icon makes the window fill the entire Raven 
desktop. When the window is maximized, you’ll notice the Maximize 
button changes into a Restore button. Clicking this Restore icon restores 
the sound window to its previous size and position. 

Clicking on the Close icon closes the window; if you close it, you’ll have to 
reopen the sound file again by choosing File > Open Sound Files..., by 
typing <Ctrl-O> (Windows, Linux) or <Command-O> (Mac OS), or by 
using the Recent Files section of the File menu. 

You can also resize the window by clicking and dragging on an edge or 
any corner of the window. On Mac OS, you must drag from the bottom 
right corner to resize the window.

Scrollbars The horizontal and vertical scrollbars in a Raven sound window always 
refer to the active view. The length of the horizontal scrollbar in a 
waveform or spectrogram view corresponds to the total duration of the 
sound that is in Raven’s working memory.1 The length of a scrollbar’s 
scroll thumb (Figure 3.4) relative to the length of the entire scrollbar, 
indicates what proportion of the corresponding axis is visible in the view 
pane.

1. If you opened the entire sound at once (the default), the duration of the sound 
in memory is the duration of the entire sound file or file sequence. If you 
opened the sound in a paged window, the duration in memory is the length of 
one page. See “Configuring a new paged sound window” in Chapter 7 (page 
188) for more on paged sound windows.
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Figure 3.4 Scrollbars

Figure 3.4. A sound window with its scrollbars and scroll thumbs 
labeled in red.

As touched on in “Filtered play” in Chapter 1 (page 9) the location of the 
scroll thumb within the scrollbar indicates the view’s position relative to 
the data. When the horizontal scroll thumb of a waveform or spectrogram 
is at the left edge of the scrollbar, the start of the data is aligned with the 
position marker (Figure 3.4).

Axis units in views The units used on the axes are indicated in the lower left corner of each 
view. In the waveform, the units are seconds (S) for the horizontal time 
axis, and kilounits (kU) for the vertical amplitude axis. In the spectrogram, 

Raven displays a gray background for areas in each view 
pane that are beyond the limits of the data, for example 
before the beginning or after the end of a signal in the time 
dimension.
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the units are seconds (S) for the horizontal time axis, and kilohertz (kHz) 
for the vertical frequency axis.

Major and minor
grid lines

You can choose to overlay a grid onto any of the views in Raven by 
checking the corresponding box in the layout tab of the side panel. The 
spacing of the major and minor grid lines is determined by the spacing of 
the major and minor tickmarks on an axis. You can configure which grids 
appear in which views by right-clicking on a sound (or Control+clicking 
on a Mac) and choosing Configure Grids... from the contextual menu, or 
using View> Configure Grids....

Position markers Each view that Raven displays has a horizontal and a vertical position 
associated with it, shown by a magenta line, known as a position marker. 
You have already seen how the time position marker in a waveform view 
indicates the current time during scrolling play (“Filtered play” on 
page 9).

Notice that when you move the time position of either the waveform or 
spectrogram, the time position marker in the other view moves with it. 
This is because views that share a dimension (e.g., the time dimension for 
waveform and spectrogram views) are by default linked by their position 
in that dimension. More detailed information regarding linkage of views 
is discussed in “Linking and unlinking views” on page 62. 

Centering a position You can move the horizontal or vertical position marker of a view relative 
to the window by grabbing it with the mouse and dragging it. To move a 
particular point in the data shown in a view to the horizontal or vertical 
center of the view pane, place the position marker on the point of interest, 
then click the corresponding Center Position button (Figure 3.5). The 
position marker and the underlying data will jump to the center of the 

The “units” displayed on the vertical axis of a waveform view 
are the actual sample values in the signal, which are propor-
tional to the sound pressure at the microphone when the 
sound was recorded. 

When we speak of the “horizontal position marker” we mean 
the line that marks the horizontal position, which is a vertical 
line.
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view pane. Blue labels along the axes show the exact numeric values of the 
current horizontal and vertical positions. 

Figure 3.5. Center position buttons

Figure 3.5. The horizontal and vertical Center Position buttons. 

Positions control
view appearance

and behavior

The horizontal and vertical position of a view control aspects of a view’s 
appearance and behavior in four ways:

1.  First, a view’s horizontal and vertical position, in combination with the 
view’s horizontal and vertical scales, determine what portion of the 
view’s data is visible in the window. 

2. Second, a view’s position is the point around which zoom operations are 
centered. 

3. Third, the position of a view in a particular dimension (e.g., time or 
frequency) may be used to link that view to any other view that shares 
that dimension (“Linking and unlinking views” on page 62). 

4. And fourth, during scrolling playback the time position moves through 
the data (though the position location stays fixed— see below) and can 
be used to control where playback starts (see “Filtered play” on 
page 9).

Position vs. position
location

The position of a signal identifies a point in the data along a particular axis, 
such as time or frequency. In contrast, the position location is the point in a 
particular view’s panel where the position marker is displayed, i.e., from left 
to right or top to bottom. For example, when you drag a time position 
marker, you change both the position location (relative to the window) 
and the position (relative to the data), since the data do not move with the 
marker.2 When you click the Center Position button for an axis, the 

WINDOWS
On computers running the Windows operating system, 
you can make a view’s horizontal position marker jump 
directly to a point by control-clicking at that point. 
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position marker jumps to the corresponding (horizontal or vertical) center 
of the view panel, and the data move with it— i.e., the position location 
changes, but the position (relative to the data) does not. 

Figure 3.6.  Centered pos markers w/gray bkgrd

Figure 3.6.   Waveform and spectrogram views with centered position 
markers, positioned at the start of the signal (left edge of horizontal 
scrollbar) and the lowest frequency (bottom end of vertical scrollbar) of 
the spectrogram. The vertical scrollbar refers to the spectrogram view, 
because the spectrogram is the active view.

Scale of a view Each view that Raven displays has a horizontal and vertical scale 
associated with it. The scale determines the relationship between the 
dimensional units shown along that axis (e.g., seconds or kilohertz) of the 
view and display units (e.g., pixels, centimeters, or inches) on your 
computer screen. The scale at which the entire extent of an axis just fits in 
the view pane is called the default scale for that axis. When you first open a 
sound file, the time scale of the waveform view is set to the default. When 
you first create a spectrogram (information on creating views will be 
discussed later in the chapter) the frequency scale is set by default so that 
the entire frequency range of the signal fits vertically in the spectrogram 
pane.

Setting the scale of
view axes

The scale and position of the horizontal and vertical axes of any view can 
be changed using the zoom controls and scrollbars, as described in the 
next section. However, more precise control of scale and position is 
available in the Configure View Axes dialog box (Figure 3.7). To display 
the Configure View Axes dialog box, choose Configure View Axes... from 
the contextual menu for any view or from the View menu for the active 

2. The one exception is when you try to drag the position marker beyond the lim-
its of the signal. In that case, the end point of the signal will move with the 
marker, and you will be changing the position location but not the position 
(which is set to one of its limits already).
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view. You can enter precise values for the position and scale of the view’s 
horizontal and vertical axes. Scale is specified in units per line of the view 
(see “Multiple-line views within sound windows” on page 74).

Figure 3.7 Changing time scale

Figure 3.7. The original file (top left) is shown with the default time 
scale. Below that (bottom left) is the sound with its time scale changed 
to 10 Seconds/Line. The Configure View Axes box is shown (right) with 
the edited time scale displayed. You can see the original view shows 
more than 20 seconds of the signal, while the bottom view (with the 
altered time scale) shows only 10 seconds of the signal across the line.

Changing view
scales by zooming

At the scale of magnification shown in Figure 3.6, you can’t see individual 
cycles of oscillation of the waveform view (top); what you see is the 
envelope of the entire signal. In order to see more detail of a signal, you 
must adjust the zoom level of the view. In the lower right-hand corner of a 
Raven sound window are the zoom controls for the active view (Figure 
3.8). Buttons marked with ‘+’ and ‘-’ at the right and bottom ends of the 
horizontal and vertical scrollbars respectively increase and decrease 
magnification (zoom in and out) around the current position along that 
axis. 
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Figure 3.8. Zoom buttons

Figure 3.8. The zoom controls, which apply to the active view. The 
Zoom to Selection button is gray if no selection exists in the signal.

Zoom details Each time you click a Zoom In or Zoom Out button, the corresponding axis 
of the active view is re-scaled by a factor of  (= 1.41). Thus, clicking the 
Zoom In or Zoom Out button twice in succession changes the scale by a 
factor of 2. To zoom in horizontally on a view, first make sure that view is 
active, then move the horizontal position marker to the point where you 
want to center the zoom. Click the ‘+’ button at the end of the horizontal 
scrollbar, and observe how the display changes. Clicking the ‘-’ button 
reverses the change. 

Each time that you zoom in or out horizontally or vertically, the 
corresponding scroll thumb shortens or lengthens to indicate what 
proportion of the signal is visible. (Remember that the scroll thumb is half 
the length of the scrollbar when that axis’s scale is set to its default value.) 

Zooming in
horizontally

If you click the horizontal ‘+’ (zoom in) button repeatedly the scale will 
eventually be stretched to the point where Raven displays the individual 
samples in the waveform as dots (Figure 3.9). 

2
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Figure 3.9 Zoom to Sample Points

Figure 3.9. A sound window with its waveform view (top) horizontally 
zoomed in enough to display individual sample points.

As mentioned before, the spectrogram and waveform views are linked by 
their time scale (and time positions.)  So, you’ll notice that both the 
waveform and spectrogram views zoomed in, even though only one of 
them is the active view.

Zooming vertically To zoom vertically in the spectrogram, activate that view, and drag the 
vertical position marker to the point where you want to center the zoom. 
Click the ‘+’ or ‘-’ button at the bottom of the vertical axis to increase or 
decrease magnification around the vertical position marker.

Notice that changing the vertical position or scale of the spectrogram has 
no effect on the waveform. The vertical dimensions of the views are 
different (amplitude in the waveform, frequency in the spectrogram), so 
the vertical scales of the views cannot be linked.

Zoom to all To reset the horizontal or vertical scale of a view to display the entire axis, 
click on the corresponding Zoom To All button, marked with a horizontal 
or vertical I-beam icon (Figure 3.8, page 54).

Zoom to selection The Zoom To Selection button rescales the active view so that the active 
selection fills the view frame. If there is no active selection, the Zoom To 
Selection button is not available. In the spectrogram view, select a 
rectangular  area to enlarge by clicking and dragging the mouse pointer. 
Then click on the Zoom To Selection button in the lower right corner of the 
sound window (Figure 3.8, page 54).
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View Types

The six main view
types

Waveform view

When you open a sound in Raven, the top view in a sound window is a 
waveform view by default. This view displays an oscillogram which is a 
graph of the sound showing amplitude versus time.

Spectrogram view

The second view shown by default in a sound window, below the 
waveform view, is a spectrogram view.  It shows time on the horizontal 
axis, frequency on the vertical axis, and relative power at each point as a 
color (grayscale by default.)

Spectrogram Slice view

A spectrogram slice view is a plot of relative intensity versus frequency at 
a particular point in time within a signal. A spectrogram slice represents a 
vertical cross section through a spectrogram at a single time, but is rotated 
90° so that the frequency axis is horizontal. In fact, a spectrogram is built 
of a series of spectrogram slices stacked side by side (with their frequency 
axes running vertically). 

Where a spectrogram view shows a series of slices at successive points in 
time, and represents power at each frequency by a color value, a 
spectrogram slice view shows only one slice and represents power at each 
frequency on a line graph. The relationship between spectrogram and 
spectrogram slice views is explained in more depth in Chapter 5, 
“Spectrographic Analysis”.

Selection Spectrum view

These show the average spectrum of a sound over the time interval 
defined by a user-made active selection.  More information about 
selections and how they affect this view type can be found in “Selection 
spectrum views” in Chapter 5 (page 139).

Beamogram View

Beamforming provides a means for determining a sound source's likely 
bearing relative to a multi-channel array of sensors. The beamogram view 
creates a plot of potential bearing angles versus time. Areas of higher 
energy in the beamogram view correspond to greater likelihood that 
specific angles represent actual sound source bearings. More information 
about determining source directions using the beamogram view can be 
found in “Bearing analysis: Beamforming, Beamogram View, and Max 
Bearing Measurement” in Chapter 8 (page 213). 
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Beamogram Slice view

The beamogram slice view represents a vertical cross section of the 
beamogram view, showing the potential bearing angles at a specific point 
in time. Potential bearing angles are plotted on the horizontal axis, with 
vertical values corresponding to the likelihood that a sound is coming 
from the corresponding direction. More information regarding the 
beamogram slice view and its relation to the beamogram view can be 
found in  “Bearing analysis: Beamforming, Beamogram View, and Max 
Bearing Measurement” in Chapter 8 (page 213).

Color Bar View

A color bar view serves as a key to the current spectrogram color scheme. 
It displays the spectrum of colors in the color scheme along with their 
associated intensity values. While this view contains no new information 
about the sound, it can be helpful for visually interpreting spectrograms.

Making a new view New views are created by using the appropriate buttons located on the 
view toolbar (Figure 3.10).

Figure 3.10 New view buttons on the control toolbar

Figure 3.10. The new view buttons on the view toolbar.

Open a sound file like ChestnutSidedWarbler.aif. The sound window 
shows a spectrogram and waveform view by default.  To create a new 
view, like a spectrogram slice view, simply click on the New Spectrogram 
Slice button in the view toolbar.  Alternately, you can choose View > New > 
Spectrogram Slice View..., or type <Ctrl-L> (Windows, Linux) or 
<Command-L> (Mac OS). The Configure New Spectrogram Slice View 
dialog box should appear (Figure 3.11.).
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am Slice View dialog box

Figure 3.11. The Configure New Spectrogram Slice View dialog box.

This dialog box lets you specify various parameters that affect the 
appearance of the spectrogram. For now, don’t worry about what these 
parameters mean; they are explained in detail in “Configuring 
spectrographic views” in Chapter 5 (page 112). Click OK to accept the 
default settings and compute the spectrogram slice view.

The sound window is re-drawn with an additional view pane, containing 
the new spectrogram slice view. If the time position marker of the 
waveform or spectrogram view is at the very beginning of the data (where 
Raven puts it by default when opening a new signal) the spectrogram slice 
view does not display any data (Figure 3.12). 
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Figure 3.12 New Spectrogram Slice View

Figure 3.12. This sound window contains the usual waveform and 
spectrogram views, but it also contains a blank spectrogram slice view 
as well.  The spectrogram slice view displays no data when the time 
position marker of the spectrogram and waveform view is located at the 
start of the data (all the way to the left).

Showing data in a
new view

To see valid data, drag the time position marker to the right in either the 
waveform or spectrogram view (Figure 3.13). (For a complete explanation 
of why no data are visible in the spectrogram slice view when the position 
marker is at the start of the signal, see Chapter 5, “Spectrographic 
Analysis”.)
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Figure 3.13 Spectrogram Slice view with data

Figure 3.13. The same sound window as shown in Figure 3.12 but with 
the time position marker (the vertical magenta line) moved to a position 
in the waveform and spectrogram data.  The spectrogram slice view 
now displays the data from the time designated by the time position 
marker.

Selected view
dictates toolbar

content

Remember that the active view in a sound window is marked by the 
highlighted view selection button to the left of the view (for example, the 
spectrogram view is active in Figure 3.13). The activated contents of the 
toolbars are dictated by which view is active in the current sound window.  
For example, if a spectrogram view is active, the brightness and contrast 
sliders in the spectrogram toolbar become active (Figure 2.12 on page 37). 
If any of the other views are active, the brightness and contrast sliders are 
grayed out because they have no relevance in those cases.

The zoom window The zoom window is a separate window on the Raven desktop that can be 
used to view selections from any open sound. Once a zoom window is 
opened, it displays a magnified view of the active selection of the active 
sound. If the zoom window is the active window, it will display the active 
selection from the previously active sound. The zoom window 
automatically updates as you move through selections in a sound, making 
it particularly useful for browsing details of selections without having to 
manually zoom in on each one before advancing. 

To open a zoom window, choose Zoom Window from the Window menu. 
You can configure the views or change display settings in the zoom 
window through the context menu or side panel in the same way as other 
sound windows. These settings are applied specifically to the zoom 
window, and override the display settings of the original sound when 
displaying selections. For multi-channel files the zoom window only 
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displays the channels containing the active selection; however, you can 
choose to add other channels from the side panel. Figure 3.14 shows the 
default zoom window with the parent sound window for a selection. 

Figure 3.14Zoom Window

Figure 3.14. The zoom window displays a magnified view of the active 
selection, showing only those channels that contain the selection.

When the zoom window is active the cursor will change from its current 
setting to a play cursor, allowing you to play the selection simply by 
clicking in the zoom window. This is the case for both the create selection 
and activate selection modes. However, the Grab and Scroll mode retains 
its normal function in the zoom window.  

When a workspace is saved, the zoom window’s visibility and settings will 
be saved as well. However, if the zoom window is active when the 
workspace is saved, its contents may not be fully restored. If another 
sound window is active, however, the zoom window will restore 
accordingly.
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Linking and unlinking views

Two views that share a dimension— such as time or frequency— can have 
their positions and scales either linked or unlinked by that dimension. When 
the positions of two views are linked, moving the position of either one 
(by moving the corresponding scroll thumb, or by moving the position 
marker within the window) causes the positions of both views to move 
together. When the scales of two views are linked, changing the scale of 
either one (using the zoom buttons) causes both views to be re-scaled. In 
the examples you’ve seen so far, waveform and spectrogram views have 
been linked by time position and in time scale.

When you open or record a signal and create multiple views, each view is 
initially linked in position and scale to every other view that shares its 
dimensions. For example, waveforms and spectrograms are initially all 
linked to each other in time position and time scale, and spectrogram and 
spectrogram slice views are linked in frequency position and frequency 
scale. Spectrograms and waveforms cannot be linked in frequency because 
waveforms have no frequency dimension.

Unlinked views In some situations, it can be useful to work with views that are unlinked 
from each other in particular ways. For example, Figure 3.15 shows two 
spectrogram views of a signal that is 53 seconds long. The views are linked 
in time position but unlinked in time scale. Unlinking the time scales 
makes it possible to view simultaneously an eight-second portion segment 
of the signal (upper view), and a close-up of a two-second segment 
contained within it (lower view). Since the two views remain linked in 
time position, the position markers provide a reference point to show 
where the close-up view is located within the entire signal. As either view 
is scrolled horizontally through the signal, the linked position markers 
identify the same point in time in both views. 
62 Raven Pro 1.4 User’s Manual



Chapter 3:  Visibility, Views, & Navigation
Figure 3.15.  Two linked spgs, diff time scales

Figure 3.15.  Two spectrogram views of the file “BlackCappedVireo.aif” 
that are linked in time position, but unlinked in time scale. The upper 
spectrogram shows 7.8 seconds of the signal; the lower spectrogram is 
a close-up of 2.0 seconds. The highlighted rectangle identifies the 
same selection in both views. The time position markers in both 
spectrograms identify the same time, because the time positions are 
linked.

Unlinking views
through the

contextual menu

To create two spectrograms that are unlinked in time scale as discussed in 
the above example (Figure 3.15):
1. Open a signal.
2. Make a second spectrogram by clicking the New Spectrogram button 

(Figure 3.10, page 57), or typing <Ctrl-G> (Windows, Linux) or 
<Command-G> (Mac OS).

Place the mouse pointer on the second spectrogram, activate the 
contextual menu, and choose Unlink View > Time Scale.

Now try using the zoom buttons to change the time scale of the first 
spectrogram. Notice that the time scales of the waveform and the first 
spectrogram change together, but the time scale of the second spectrogram 
does not change. If you activate the second spectrogram, and zoom in 
time, its time scale changes, while the time scales of the waveform and the 
first spectrogram remain unchanged. If you scroll any of the three views, 
their position markers will move in synchrony, because all three are still 
linked by time position.
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Restoring or
creating new

linkages through
the linkage tab

To restore linkages between views that have been unlinked, or to create 
linkages between views that have never been linked, activate the Linkage 
tab in the Raven side panel. (If the side panel is not visible, click on the 
right-pointing triangle at the top (Windows, Linux) or bottom (Mac OS) of 
the separator bar at the left edge of the Raven window.)

At the top of the Linkage tab, there is a drop-down menu showing all of 
the linkable properties of the current views. Click on this menu, and 
choose Time Scale. If you created two spectrograms and unlinked them as 
described above, the tab will display three folder icons representing 
linkage groups, with names like “Group 1”, “Signal 1 Default”, and “New” 
(Figure 3.16). (The second group may be called “Signal 2 default”, “Signal 
3 default”, etc., depending on how many signals you’ve opened in the 
current Raven session. If more than one signal is open, you will see a 
default linkage group for each signal.)

Figure 3.16 .  Linkage tab.

Figure 3.16.  The Linkage tab, showing the linkage groups for the Time 
Scale property corresponding to Figure 3.15

A linkage group is a set of views that are linked to each other by a 
particular property (in this case, Time Scale). Views that are in different 
linkage groups are unlinked from each other in that property. 

Open the first two folders by double-clicking on them (or single-clicking 
the icon to the left of each folder icon). In the present case, the linkage 
group called “Sound 1 Default” contains the views called “Sound 1 
Waveform 1” and “Sound 1 Spectrogram 1”; Group 1 contains “Sound 1 
Spectrogram 2”. The active view is highlighted, and you can activate a 
different view by clicking on its name. 

To link two views that are presently unlinked, drag the icon for one of the 
views to the linkage group that contains the other. In the case shown in 
Figure 3.16, you can unlink the waveform from Spectrogram 1 and link it 
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to Spectrogram 2 by dragging its icon from the Default folder to the Group 
1 folder. 

When you move a view from one linkage group to another, the view is 
immediately redrawn if necessary so that its image has the correct scale, 
position, or other linkable property. If a linkage group contains only a 
single view, and you drag that view to a different linkage group, the 
original (now empty) group disappears.

Creating a new
linkage group

To create a new linkage group select one of the views listed by clicking on 
it, and drag it onto the folder labeled “New”. A new linkage group will 
appear in the list, containing the view that you moved.

Creating new linked
views

To create a new spectrogram, spectrogram slice, or selection spectrum 
view that is linked by spectrogram parameters to an existing 
spectrographic view, choose New > Similar Spectrogram View, New > 
Similar Spectrogram Slice View, or New > Similar Selection Spectrum View 
from the contextual menu for any spectrographic view, or from the View 
menu for the active spectrographic view.

Other linkable
properties

In addition to its position and scale for each of its dimensions, every view 
has four other properties by which it can be linked to other views:
•Position Location: Moving the location of the time or frequency position 

bar in a view will also move the corresponding position bar in other 
views that are linked by Position Location.

•Color Scheme:  Color schemes include color specifications for most of 
the graphical elements shown in a view (e.g., axes, backgrounds, 
selection boundaries), as discussed later in this chapter. Adjusting 
brightness and contrast settings for a spectrogram adjusts the settings for 
all spectrograms linked to it by Color Scheme. By default all views of a 
signal are linked to each other by Color Scheme.

•Channel Visibilities:  In multi-channel signals (see Chapter 8, “Multi-
channel Sounds”), hiding or showing particular channels of a view will 
also hide or show those channels in other views that are linked by 
Channel Visibility.

•Number of Lines:  Changing the number of lines displayed for a view  
(see “Multiple-line views within sound windows” on page 74) 
automatically changes the number of lines displayed for any other views 
that are linked by Number of Lines. By default, all views in a signal that 
display a time axis are linked to each other by Number of Lines.

Additionally, spectrogram, spectrogram slice, and selection spectrum 
views can be linked by spectrogram parameters. If two views are linked 
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by spectrogram parameters, then changing the parameters for either view 
automatically changes both views. 

Linkage between
spectrogram and

spectrogram slice
views

When you request a spectrogram slice view, Raven actually calculates an 
entire spectrogram of the signal, but only displays one slice at a time. A 
spectrogram slice view thus has a “hidden” time axis. Which slice of the 
underlying spectrogram is displayed is determined by the view’s time 
position. By default, the time position of a spectrogram slice view is linked 
to the time positions of waveform and spectrogram views. As you move 
the time position marker of a spectrogram view, any spectrogram slice 
view that is linked to it is continually updated to show the cross-section of 
the spectrogram at the time position marker.

By default, new spectrogram and spectrogram slice views are also linked 
to each other by frequency position and frequency scale. When you move 
the frequency position of a spectrogram, the frequency position of any 
linked spectrogram slice views move as well, and vice versa. Similarly, 
when you zoom the frequency scale of any spectrogram slice view, the 
frequency scale of any linked spectrogram zooms as well. It is important 
to remember that the frequency scales of spectrogram and spectrogram 
slice views are rotated 90° from each other.

 Controlling how views are displayed

Using tools and commands in the side panel’s Layout tab and in the View 
menu, you can rearrange the order of views and hide or show the non-
data components of views such as the axes and position markers.

Another way to hide a view is to activate that view and choose Hide View 
from the View menu, or from that view’s contextual menu.

Deleting a view To delete a view, activate the view and choose Delete View from its 
contextual menu or from the View menu. When you delete a view (as 
opposed to hiding it), the memory occupied by that view is released for 
reuse. Re-displaying a hidden view occurs instantly, whereas re-

Views that share a linkable property can be linked even if they 
are in different signal widows. This can be useful for example 
in setting views of different signals to the same scale.

Even though a spectrogram slice view has a time position, it 
does not have a time scale, since the time axis of the underly-
ing spectrogram is not displayed.
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displaying a view that was deleted requires that it be recalculated, which 
may take a significant amount of time.

Changing the order
in which views are

displayed

To rearrange the order in which views are displayed in the sound window, 
you can drag and drop view names in the Layout tab.

You can also move a view up or down within the sound window by 
choosing Move View Up or Move View Down from the View menu or the 
view’s contextual menu.

Hiding and showing
window

components

The bottom pane of the side panel’s Layout tab contains a list of window 
components that can either be displayed or hidden. You can display or hide 
each component of the active window by checking or unchecking its 
checkbox. Figure 3.17. shows a sound window containing two views, with 
all components hidden.

Figure 3.17..  All components hidden.

Figure 3.17.  A sound window with all components hidden.

By default, all window components are displayed except for line titles, 
which identify the view type and number of each view (Figure 3.18.). If the 
sound has multiple channels (see Chapter 8, “Multi-channel Sounds”) or a 
view has multiple lines, channel and line numbers are displayed in line 
titles as well.

When you activate a contextual menu in a view pane, view-
specific commands in the menu apply to whichever view the 
mouse pointer is on when the menu is activated, irrespective 
of whether or not that view is active.
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Figure 3.18. .  View titles.

Figure 3.18.  A sound window showing a waveform and a spectrogram 
view, with line titles displayed.

Changing the Appearance of a Sound Window

Spectrogram
brightness and

contrast

When a spectrogram view is active, the brightness and contrast controls 
on Raven’s spectrogram toolbar become active too (Figure 2.12 on page 
37).

If your spectrogram looks too dark or light, or if it’s hard to pick the signal 
out of the background, move the brightness and contrast sliders to achieve 
the desired appearance of the spectrogram. The brightness control adjusts 
the overall darkness of the spectrogram: for a grayscale spectrogram (the 
default), sliding the control to the right lightens the display.

The contrast control adjusts the number of different color (by default, 
grayscale) values that are shown in the spectrogram. In a grayscale 
spectrogram, moving the contrast slider all the way to the right makes the 
display black and white: all values below some threshold are assigned to 
white and the rest become black. In this case, the threshold between black 
and white is determined by the brightness control. With the contrast 
control all the way to the left Raven displays up to 200 shades of gray.

The box next to each control tells you what percent contrast or brightness 
you’ve set. If you prefer, you can type a percentage number into a box 
instead of moving the slider.

In addition to the toolbar controls, you can also configure spectrogram 
brightness and contrast by choosing Configure Brightness and Contrast... 
from a view’s contextual menu. In addition to a set of brightness and 
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contrast sliders, the resulting dialog allows you to alter these parameters 
by specifying floor and ceiling values for the spectrogram and displays a 
plot illustrating how colors are assigned to each value in a spectrogram. 
The floor and ceiling threshold parameters determine the power levels 
beyond which all values are assigned the same color. In the case of a 
grayscale spectrogram, values below the floor threshold are all displayed 
as white, and values above the ceiling threshold are all displayed as black. 
For more information on the relationship between these threshold 
parameters and corresponding brightness and contrast values, see 
“Brightness and contrast” in Chapter 5 (page 130).

Figure 3.19Brightness and Contrast Dialog

Figure 3.19. The configure Brightness and Contrast dialog

Color schemes of
sound windows

Each view in a sound window has a particular color scheme. A color 
scheme consists of a spectrogram colormap and particular colors for items 
such as plottable measurements, active and inactive selection borders and 
fills, and the waveform line. 
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A spectrogram colormap defines the relationship between power values in 
the spectrogram and colors used to display them. Raven provides six 
predefined colormaps: Grayscale, Hot, Cool, Standard Gamma II3, Bone, 
and Copper (Figure 3.20.). You can also create customized colormaps as 
text files as described in “Creating customized colormaps” in Chapter 11 
(page 296). To change the colormap of a spectrogram, choose Color 
Scheme > Colormap-name from the spectrogram’s context menu, or from 
the View menu when the spectrogram is active. You can reverse the 
spectrogram colormap by choosing Color Scheme > Reverse Color Map 
from the spectrogram’s context menu, or from the View menu when the 
spectrogram is active. To display the spectrum of colors in the color map 
along with their associated intensity levels, you can add a color bar view 
to the sound window by clicking on the icon in the view toolbar or 
through the View > New menu.

3. The Standard Gamma II color map is included in Raven courtesy of Research 
Systems, Inc., a Kodak Company.

Views in a sound window are by default linked to each other 
by color scheme. If you change the colormap or any other 
item in a view’s color scheme, the affected colors will also 
change in any other views that are linked to it by color 
scheme.
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Figure 3.20..  Colormap examples

Figure 3.20.  Four spectrogram views of the signal 
“CassinsKingbird.wav”, using four different, predefined colormaps. (a) 
Hot. (b) Standard Gamma II. (c) Bone. (d) Copper.

You can reverse the spectrogram colormap by choosing Color Scheme > 
Reverse Color Map from the spectrogram’s context menu, or from the 
View menu when the spectrogram is active.

Editing color
schemes

In addition to selecting spectrogram colormaps, you can also edit a view’s 
color scheme by choosing Color Scheme > Edit... from the view’s context 
menu, or from the View menu when the view is active. More information 
on customizing color schemes can be found in “Editing color schemes” in 
Chapter 11 (page 289).

Sound Window
Presets

You can save information about the layout of a sound window in a window 
preset, which you can later apply to another sound window (or to the same 

In general, if the background of a spectrogram is white, then 
light colors represent low power.  If the background is black, 
the dark colors of a colormap represent the low power.
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window). A window preset includes information about the size of a 
window, what views are displayed, whether or not the selection table is 
showing, and other properties (Table 3.1).
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To save a window preset, first configure the properties listed in Table 3.1 
the way you want to save them, then choose View > Window Preset > 
Save As... . When the Save Sound Window Preset dialog box appears, 
enter a name for the preset, and click OK. 

To apply a window preset that’s already been saved to the active sound 
window, choose View > Window Preset > Preset-name. When you apply a 
saved preset, the active window is redrawn with the properties specified 
in the preset, and any additional views are calculated as needed. If any of 
the open selection tables contain annotation columns, Raven will display a 
dialog where you can choose to keep, replace, or merge these columns 
with those in the preset.

Table 3.1.  Window properties saved in window presets.

window size

view types, parameters, color schemes, 
    positions, scales, sizes

spectrogram parameters

spectrogram brightness and contrast

selection table visibility and size

measurement list and annotation columns

selection label configuration

selection label visibility

axis visibility

major and minor grid visibility

line title visibility

position marker visibility

view selection button visibility

scrollbar visibility

Window presets must be saved in the folder Presets/
Sound Window/ within the Raven program folder. You can 
also create additional folders within the Sound Window 
folder by clicking on the New Folder icon within the Save 
Sound Window dialog. These folders will appear as sub-
menus in the Window Preset menu, with each submenu list-
ing the presets in the corresponding folder.
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You can specify a window preset to apply when you first open a sound file 
in the Configure New Sound Window dialog box (Figure 1.3, page 4). You 
can change the name of the default window preset by editing the Raven 
preferences file, as described in “About Raven preferences” in Chapter 11 
(page 299). 

If you make changes to the properties of a window to which you’ve 
applied a preset, you can save the changes to the current preset by 
choosing View > Window Preset > Save “Preset-name”.

Multiple-line views
within sound

windows

Raven can display views that have a time axis (i.e., waveforms and 
spectrograms) across multiple lines (Figure 3.21). The values shown on the 
time axis of a multiline view start at the left end of the top line, go to the 
right end of that line and continue on from left to right on subsequent 
lines, like lines of text on a page.

Window presets take precedence over other presets that 
affect the appearance of the contents of a window. Thus, if 
you apply a window preset, spectrogram parameters, the 
measurement list, and the color scheme are all set as defined 
in the specified window preset, even if they were previously 
set to different values by choosing spectrogram, measure-
ment, or color scheme presets. 
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Figure 3.21.  Multi-line spg.

Figure 3.21.  A spectrogram view with three lines. Note the continuity 
of the time axis from one line to the next.

On the side panel, the Layout tab’s Lines box shows you how many lines 
there are for the selected view. To change the number of lines, select a 
waveform or spectrogram view, change the number in the box, and press 
<Enter>. By default, all waveform and spectrogram views in a sound 
window are linked to each other in the number of lines displayed. You can 
unlink the number of lines property as described in “Linking and 
unlinking views” on page 62.

Grouping views
with multiple lines

In sound windows with two or more views and two or more lines per 
view, you can change the way the lines and views are grouped in the 
window. By default Raven displays all the lines for one view, followed by 
the lines for the next; this is called grouping by view (Figure 3.22). The 
alternative is to see all the first lines for all views, followed by all the 

The scale of the time axis doesn’t change when you change 
the number of lines displayed. To rescale the axis so that the 
view fills the available lines, click on the horizontal Zoom-to-
All button at the right end of the horizontal scrollbar.
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second lines for all views, and so on; this is called grouping by time (Figure 
3.23).

Figure 3.22.  VL grouping.

Figure 3.22.  A sound window containing two views, each with two 
lines, grouped by view. All lines of the waveform view are in the top 
group, all lines of the spectrogram view are in the next group. 
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Figure 3.23.  LV grouping.

Figure 3.23.  The same two views shown in Figure 3.22, but grouped 
by time. The first lines of both views are in the top group; the second 
lines of both views are in the next group. 

To change the grouping, choose View or Time from the pull-down menu 
labeled “Group By”, in the side panel’s Layout tab.

Working with more
than one sound

Raven lets you work with more than one sound at a time. When more than 
one sound window is open, the tools in Raven’s toolbar (e.g., New View 
buttons, brightness, contrast, and playback controls) and in the side 
panel’s Layout and Playback tabs always refer to the active window (the one 
window in which the title bar is colored). The side panel’s Linkage tab 
shows views for all sounds that are open, since Raven lets you link views 
of different sound windows to each other. You can activate a sound 
window by clicking anywhere in it with the mouse. You can also activate a 

The horizontal separator bar that Raven displays between 
top-level groupings (i.e., between views in View grouping or 
between lines in Time grouping) is wider than the bar used 
between second-level groups.
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window by choosing its name from the Window menu, or by clicking on 
the name of one of its views in the side panel’s Linkage tab.

Tile/Cascade
windows

When you have multiple sound windows open, Raven can arrange them 
neatly for you on the desktop. If you choose Window > Tile Windows, 
Raven resizes and repositions all of the windows so that they are all the 
same size and fill the desktop (as nearly as possible) without overlapping 
each other. Choosing Window > Tile Windows Horizontally arranges the 
windows in a row such that they are all the same width and fill the 
desktop. Similarly, choosing Window > Tile Windows Vertically arranges 
the windows in a column such that they are all the same height and fill the 
width of the desktop. See Figure 3.24 for examples of these tiling options.

If you choose Window > Cascade Windows, Raven resizes and repositions 
all of the windows so that they are all the same size and as large as 
possible, overlapping so that their title bars are all visible (Figure 3.25).
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Figure 3.24 Tile Windows

Figure 3.24. Examples of tiled sound windows (a) 2 to 3 sounds will be 
tiled in one column (b) 4 to 8 sounds will be tiled in two columns and (c) 
9 to 12 sounds will be tiled in three columns. (d) 4 windows tiled 
horizontally. (e) 4 windows tiled vertically
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Figure 3.25 Cascade Windows

Figure 3.25. An example of cascaded sound windows. Here, the 
windows are stacked on each other with all title bars visible.

Apply current
window layout to all

windows

To apply all of the active window’s layout to all currently open windows, 
choose View > Apply To All.  Window layout includes all of the information 
that would be stored in a sound window preset, including window size, 
view visibility and scale, spectrogram parameters, and spectrogram 
brightness and contrast.  A complete list of window properties affected by 
the Apply To All command is given in Table 3.1.
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